Upgrading sfGuardPlugin for symfony 1.1

Last week I upgraded my first symfony 1.0 project to symfony 1.1 following the UPGRADE file that comes with symfony 1.1

The first part of the upgrade went pretty smoothly, but my project broke due to the sfGuardPlugin. There weren’t any details about plugins in the UPGRADE doc, and removing and reinstalling it didn’t work for me.

However, this week, with the help of some friendly symfony forum users, this procedure finally worked for me:

svn rm plugins/sfGuardPlugin
svn ci plugins/sfGuardPlugin -m 'removed old version of sfGuardPlugin'
rm -rf plugins/sfGuardPlugin plugins/.channels plugins/.depdb plugins/.depdblock plugins/.filemap plugins/.lock plugins/.registry/
rm -rf cache/.pear
./symfony plugin:install sfGuardPlugin
svn add plugins/sfGuardPlugin/

my successful plugin installation looked like this:

./symfony plugin:install sfGuardPlugin
>> plugin    installing plugin "sfGuardPlugin"
>> sfPearFrontendPlugin Attempting to discover channel "pear.symfony-project.com"...
>> sfPearFrontendPlugin downloading channel.xml ...
>> sfPearFrontendPlugin Starting to download channel.xml (663 bytes)
>> sfPearFrontendPlugin .
>> sfPearFrontendPlugin ...done: 663 bytes
>> sfPearFrontendPlugin Auto-discovered channel "pear.symfony-project.com", alias
>> sfPearFrontendPlugin "symfony", adding to registry
>> sfPearFrontendPlugin Attempting to discover channel
>> sfPearFrontendPlugin "plugins.symfony-project.org"...
>> sfPearFrontendPlugin downloading channel.xml ...
>> sfPearFrontendPlugin Starting to download channel.xml (639 bytes)
>> sfPearFrontendPlugin ...done: 639 bytes
>> sfPearFrontendPlugin Auto-discovered channel "plugins.symfony-project.org", alias
>> sfPearFrontendPlugin "symfony-plugins", adding to registry
>> sfPearFrontendPlugin downloading sfGuardPlugin-2.2.0.tgz ...
>> sfPearFrontendPlugin Starting to download sfGuardPlugin-2.2.0.tgz (18,589 bytes)
>> sfPearFrontendPlugin ...done: 18,589 bytes
>> sfPearFrontendPlugin Failed to download symfony/symfony (version >= 1.1.0, version
>> sfPearFrontendPlugin <= 1.2.0, excluded versions: 1.2.0), latest release is version
>> sfPearFrontendPlugin 1.1.1, stability "stable", use
>> sfPearFrontendPlugin "channel://pear.symfony-project.com/symfony-1.1.1" to install
>> sfSymfonyPluginManager Installation successful for plugin "sfGuardPlugin"

Then I did the first couple of steps from the install again to get it working:

$ symfony propel:build-model
$ symfony propel:build-sql
$ symfony cc

But grrr… my customized authentication and signin forms are hosing it up. Time to learn more about the new release I guess.